Ruby Bundler Throws an Encoding::CompatibilityError

Author: Mike W.    Date: 2015-09-11 13:09   

When you run bundle install to store the ruby gems for your application bundler throws the following error message:

bundle install Encoding::CompatibilityError: incompatible encodings: UTF-8 and ASCII-8BIT

This is a really weird error and seemed to come out of nowhere for me.

Solution: Delete your Gemfile and retype it. Apparently an illegal character got pasted into my Gemfile. After creating a new file, the error message disappeared.